1. bibijetz30's Avatar
    my z30 have a very strong signal with 4g+ but doesn't have a BlackBerry logo on the top right corner. my problem is I cannot connect to the internet. Anyone out there have a same problem with me. I love very much my z30 its a fantastic phone.

    Posted via CB10
    11-18-14 01:59 PM
  2. Al moon's Avatar
    the bb logo only means your not connected to bberry servers so bberry related stuff wont work but your browser should be fine also what country are you in your service provider might have this blocked as well
    11-18-14 02:21 PM
  3. bibijetz30's Avatar
    thank you for the answer, my carrier is orange french. I still don't have a browser connection without BlackBerry logo and you said anything related with BlackBerry server that means BlackBerry World apps also don't work?

    Posted via CB10
    11-18-14 06:13 PM
  4. medic22003's Avatar
    Wipe it and reload the os. Had to do that with my z10 when it was doing the same thing. Obviously back it up with link first.

    Posted via CB10
    11-18-14 06:27 PM
  5. user5240's Avatar
    Is your data services on?

    Posted via CB10
    11-18-14 09:52 PM

Similar Threads

  1. Verizon Z30 w/ Leather Pocket, USB, Charger, Premium Headphones, Screen Protector
    By bighap in forum Buy, Sell, Trade - Sold / Archived
    Replies: 11
    Last Post: 11-23-14, 12:14 AM
  2. Video streaming working better on my Playbook
    By Gray in forum BlackBerry PlayBook
    Replies: 2
    Last Post: 11-19-14, 07:28 PM
  3. Replies: 2
    Last Post: 11-18-14, 03:41 PM
  4. Why can't I open BlackBerry World on my Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-18-14, 01:20 PM
  5. Why am I having issues after the upgrade to 10.2.1.3062 on Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 11-18-14, 12:09 PM
LINK TO POST COPIED TO CLIPBOARD