1. aminustar's Avatar
    My BlackBerry Z30 Bbm not working,when connected, its displays no blackberry data. I changed sim card, I downgrades the os and also upgrades it but still the problem exist. I complaints to my sim card service providers they said everything is fine from them, the issue is from the phone . Any solution?

    Posted via CB10
    06-20-15 11:45 PM
  2. Uzi's Avatar
    Have you try with WiFi only without simcard?

    Z30STA100-2/10.3.2.2252 | CB Mod
    06-20-15 11:47 PM
  3. aminustar's Avatar
    I tried still the same thing

    Posted via CB10
    06-21-15 12:03 AM
  4. Uzi's Avatar
    Press volume up and down same time until device off, do it two times in a row

    Z30STA100-2/10.3.2.2252 | CB Mod
    06-21-15 12:04 AM
  5. aminustar's Avatar
    Thanks Othman, may we chat private?

    Posted via CB10
    06-21-15 12:19 AM
  6. Uzi's Avatar
    Thanks Othman, may we chat private?

    Posted via CB10
    It's working now?

    Z30STA100-2/10.3.2.2252 | CB Mod
    06-21-15 12:24 AM
  7. aminustar's Avatar
    It did not work

    Posted via CB10
    06-21-15 08:58 AM
  8. spyeagle's Avatar
    Has it ever worked with this provider? Alot of times when this happens it is due to the APN settings not being automatically populated by your SIM Card. Verify with your provider the APN settings that should be used and configure your phone with that.
    06-21-15 02:26 PM
  9. aminustar's Avatar
    Spyeagle the normal Apn is blackberry.net, I used it and I cross checked it with my friend whom we are on the same sim card providers. We swap sim card in which my own works at his phone while his own did not work on mine. I am planning to return the phone to where I bought it

    Posted via CB10
    06-21-15 11:24 PM
  10. spyeagle's Avatar
    Seems odd that the Apn would be blackberry.net, that is usually for bbos devices that need BIS. Ask for their regular apn that they give for Android phones. BB10 only requires data, not BIS.

    Posted via CB10
    06-22-15 12:27 PM
  11. spyeagle's Avatar
    Also it's not a problem with the phone, this is a normal issue as carriers still have a confusion when it comes to bb10 vs bbos, as soon as you say BlackBerry they think you need the BlackBerry APN which is typically only good for BBOS on BIS or BES.


    Posted via CB10
    06-22-15 12:31 PM
  12. aminustar's Avatar
    O my God. I changed sim card. Why is it when I connect through wireless still the problem exist? I love z30 but it seems like I have to change it

    Posted via CB10
    06-22-15 05:24 PM
  13. spyeagle's Avatar
    Changing the sim card doesn't always automatically update the APN for that carrier. When you tried your friends sim card did you also check what their APN settings are and try those on your Z30? I can safely say 9 out of 10 times it is an incorrect APN being used or a carrier routing issue that causes this problem.
    06-24-15 08:29 AM

Similar Threads

  1. Replies: 17
    Last Post: 04-13-17, 08:40 AM
  2. Replies: 7
    Last Post: 06-21-15, 11:13 PM
  3. Z30 Speaker Issue
    By jimmi56 in forum BlackBerry Z30
    Replies: 4
    Last Post: 06-21-15, 01:16 AM
  4. How do I get my phone number shown?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 06-20-15, 07:21 PM
  5. Replies: 1
    Last Post: 06-20-15, 06:45 PM
LINK TO POST COPIED TO CLIPBOARD