1. CrackBerry Question's Avatar
    I lost the sound from my speaker on the Z10 How do I fix it?
    07-01-16 10:31 AM
  2. Brianch85's Avatar
    How old is the phone and is it like the classics looks like It has both speakers but is only one


    Posted via CB10
    07-01-16 11:42 AM
  3. Fret Madden's Avatar
    I lost the sound from my speaker on the Z10 How do I fix it?
    I had this happen a year and a half ago - shut it down, pop off the back and remove the battery, put the back on without the battery. With the screen up, palm the bottom so your fingers land on the back, then give the phone a twist in both directions a couple times (not too hard). Put the battery back in and see if it works; might need a repeat or two.

    It sounds fantastic but it's what worked for me in the end, after a week of trying different autoloaders, device wipes, and resets. Hopefully it works for you too.
    07-01-16 12:03 PM
  4. Fret Madden's Avatar
    Also check your sound settings if you haven't already.
    07-01-16 12:04 PM

Similar Threads

  1. my bb 10 keeps saying this tag is blank or unrecognized
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-23-16, 04:00 PM
  2. Is Priv vulnerable to the Snapdragon security crack?
    By jope28 in forum News & Rumors
    Replies: 18
    Last Post: 07-06-16, 04:06 AM
  3. What is the last working patched version of Google Maps on BB 10.3
    By huntedsnake in forum Android Apps (Amazon Store & APK Files)
    Replies: 3
    Last Post: 07-01-16, 02:15 PM
  4. Replies: 1
    Last Post: 07-01-16, 11:53 AM
  5. Oh my God oh my God oh my God oh my God
    By harsh2003web in forum BB10 Leaked/Beta OS
    Replies: 8
    Last Post: 07-01-16, 08:57 AM
LINK TO POST COPIED TO CLIPBOARD