1. AkshayBalgi's Avatar
    My device shows 83% battery life and still is shutting down. This has happened after my recent upgrade to10.3.1.1779

    Posted via CB 10 from z10
    03-31-15 08:29 AM
  2. RazzBerry's Avatar
    And what model do you have and how old is the battery?
    03-31-15 08:37 AM
  3. shorski's Avatar
    If you are using a z10 then it's a common thing especially if it is the stl100-1 model. And this has been discussed a bunch of times in this forum but no definite solution.
    03-31-15 08:40 AM
  4. AkshayBalgi's Avatar
    Yes it's a STL100 and the battery is less than 6 months old.

    Posted via CB 10 from z10
    03-31-15 08:54 AM
  5. RazzBerry's Avatar
    Yes it's a STL100 and the battery is less than 6 months old.

    Posted via CB 10 from z10
    I spent all my time charging my Z10 and now own a Passport and use my Z10 as an alarm clock. Prettiest alarm clock I have ever owned! LOL!
    03-31-15 10:05 AM
  6. AkshayBalgi's Avatar
    In that case I must say my alarm clock performs some better functions than just time keeping. I am in no intention to upgrade my alarm clock !!LOL

    Posted via CB 10 from z10
    03-31-15 11:50 AM
  7. Dave Bourque's Avatar
    If you are using a z10 then it's a common thing especially if it is the stl100-1 model. And this has been discussed a bunch of times in this forum but no definite solution.
    It's a common problem with stl100-1. Not the other Z10s.

    Posted via CB10
    03-31-15 12:00 PM
  8. AkshayBalgi's Avatar
    It's a common problem with stl100-1. Not the other Z10s.

    Posted via CB10
    I charged it to 100% yet again at 92% after about 2hrs it has switched off...... So what should I do now? Its not switching on
    03-31-15 12:34 PM
  9. shorski's Avatar
    It's a common problem with stl100-1. Not the other Z10s.

    Posted via CB10
    Some have reported the same issue with other z10s but it gets fixed quicker unlike the stl100-1
    03-31-15 02:19 PM
  10. shorski's Avatar
    I charged it to 100% yet again at 92% after about 2hrs it has switched off...... So what should I do now? Its not switching on
    Try this.
    Take out the battery and plug the phone to the socket. After 1 minute, put back the battery while still being plugged in. Leave it to fully charge. If this didn't work, try this.
    When it switches off again, remove the battery and put the phone down for about 3-5 hours. Then put the battery back and charge it to full.
    03-31-15 02:25 PM
  11. AkshayBalgi's Avatar
    Try this.
    Take out the battery and plug the phone to the socket. After 1 minute, put back the battery while still being plugged in. Leave it to fully charge. If this didn't work, try this.
    When it switches off again, remove the battery and put the phone down for about 3-5 hours. Then put the battery back and charge it to full.

    Okay let me try this now. Thanks so much

    Posted via CB 10 from z10
    03-31-15 10:04 PM
  12. AkshayBalgi's Avatar
    Try this.
    Take out the battery and plug the phone to the socket. After 1 minute, put back the battery while still being plugged in. Leave it to fully charge. If this didn't work, try this.
    When it switches off again, remove the battery and put the phone down for about 3-5 hours. Then put the battery back and charge it to full.

    That helped. Thanks.

    Posted via CB 10 from z10
    04-01-15 06:30 AM
  13. Tejpal Singh2's Avatar
    Nice solution but it's for sometime not permanent solution

    Posted via CB10
    04-01-15 07:51 AM
  14. shorski's Avatar
    Nice solution but it's for sometime not permanent solution

    Posted via CB10
    Yes it isn't a permanent solution. In fact, there is no known permanent solution to the z10 stl100-1 battery calibration issues yet. But the above solution gives the user peace of mind for a couple of days as long as the user makes sure the phone is always with a significant percentage of battery, like 40%.
    04-01-15 08:49 AM
  15. shorski's Avatar
    That helped. Thanks.

    Posted via CB 10 from z10
    As noted by Tejpal, it is not a permanent solution.
    But always make sure, your phone does not go below 40% at least. No guarantees but this way, you won't have to be recalibrating the battery all the time.
    04-01-15 08:51 AM
  16. AkshayBalgi's Avatar
    As noted by Tejpal, it is not a permanent solution.
    But always make sure, your phone does not go below 40% at least. No guarantees but this way, you won't have to be recalibrating the battery all the time.
    Now is this a battery problem or that of the software?

    Posted via CB 10 from z10
    04-01-15 09:32 PM
  17. shorski's Avatar
    Now is this a battery problem or that of the software?

    Posted via CB 10 from z10
    I think it has to do with the device itself but BlackBerry knows better.

    Posted via CB10
    04-02-15 12:38 AM
  18. AkshayBalgi's Avatar
    Yeah that issue is cropping up again at 40% now


    Posted via CB 10 from z10
    04-02-15 02:12 PM

Similar Threads

  1. Replies: 7
    Last Post: 04-05-15, 12:41 AM
  2. ShopCrackBerry Easter Sale: 20% off all BlackBerry accessories!
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 03-31-15, 08:12 AM
  3. Tired of misquotes about BlackBerry?
    By RazzBerry in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 03-31-15, 08:07 AM
  4. Can u get snapchat on blackberry 10
    By richmaz3333 in forum Ask a Question
    Replies: 3
    Last Post: 03-31-15, 07:53 AM
  5. Replies: 1
    Last Post: 03-31-15, 06:43 AM
LINK TO POST COPIED TO CLIPBOARD