1. mechtuhin's Avatar
    I installed an application from Blackberry World and after that none of my application is opening. Also the mobile is not detecting sim. I tried to hard reset the mobile via Blackberry Link as well as via pressing the power + Volume up + Volume down button, but nothing is working.

    Looking for an help.
    07-27-14 06:01 AM
  2. jaydee5799's Avatar
    None of those things restarts your phone? It's still stuck?
    Last resort: remove battery. They say its not good to do but I have had to before. If you can't shut down first just pull the battery.
    07-27-14 08:46 AM
  3. FrankIAm's Avatar
    You have to hold down the buttons for about 10 seconds. IIRC, it doesn't work on the STL100-1, so try holding the power/lock button until it starts booting up again.

    Or just do as Jaydee said and remove the battery.
    07-27-14 08:50 AM

Similar Threads

  1. Replies: 11
    Last Post: 06-23-15, 09:18 AM
  2. WTS: BlackBerry Z30 STA 100-2 unlocked
    By igotberryfever in forum The Marketplace - Buy, Sell & Trade
    Replies: 22
    Last Post: 09-15-14, 06:07 PM
  3. How to download video from Facebook
    By morley412 in forum Ask a Question
    Replies: 1
    Last Post: 07-29-14, 01:15 PM
  4. I feel cheated again. Thank you BlackBerry
    By tx ram in forum BlackBerry Q5
    Replies: 89
    Last Post: 07-28-14, 08:52 AM
  5. Why I will buy the Blackberry Passport
    By antoscimento in forum General BlackBerry Discussion
    Replies: 14
    Last Post: 07-27-14, 06:39 PM
LINK TO POST COPIED TO CLIPBOARD