1. CrackBerry Question's Avatar
    The battery on my Z10 drained down to empty on Saturday, so I charged it over night. When I tried to turn it on the next day, all i got was 3 blinking lights. When I connect it to the computer to charge, the light will go on for about 10 seconds and then go out again.

    I read on the Blackberry forum that getting another charged battery should solve my problem, so I bough the Blackberry Charger and extra battery bundle. I charged the new battery over night and put it in my phone, but it STILL won't turn on or do anything but blink for a few seconds.

    What do I do now? Has anyone else had this same problem?

    Thanks!
    10-29-14 07:43 AM
  2. notfakeprofile's Avatar
    go back to the store you bought it from.. they need to check / fix it.

    I had my Z10 for 1 year and 5 months and 0,0 problems.
    10-29-14 08:11 AM
  3. Matt Somers's Avatar
    I bought the phone directly from the Blackberry website, so I will have to try to contact them to sort it out. I was hoping that the phone would last a couple years without problems and it was working perfectly until it just crashed and burned. I really like it, so I hope there is a quick fix out there.
    10-29-14 09:22 AM
  4. benbraun322's Avatar
    If you want to try something other than a store.
    Try downloading and installing an autoloader for the Z10.

    Posted via CB10
    10-29-14 09:28 AM
  5. pkcable's Avatar
    10-29-14 09:48 AM
  6. Matt Somers's Avatar
    Thanks guys. I could reload the OS or use an auto loader if the phone would turn on at all. Is it possible to do these things when the phone has no power and will not turn on at all?
    10-29-14 10:54 AM
  7. notfakeprofile's Avatar
    Thanks guys. I could reload the OS or use an auto loader if the phone would turn on at all. Is it possible to do these things when the phone has no power and will not turn on at all?
    People don't seem to read your problem..

    Send from PassportSQW100-1/10.3.1.632
    skinnymike1 likes this.
    10-29-14 11:12 AM
  8. arjun_butola's Avatar
    Hey man take out your battery, put in nw as you put in press both the volume up & down buttons together for at least 10-15 second a yellow light may blink & your phone is on.

    Posted via CB10
    10-29-14 11:14 AM
  9. serbanescu's Avatar
    You may also try this: take out the battery, wait for an hour with the battery out, put it back in after the hour passed and connect the charger. For me it worked when I had this problem.
    10-29-14 11:20 AM
  10. Matt Somers's Avatar
    that isn't working either sadly
    10-29-14 11:23 AM
  11. Matt Somers's Avatar
    I will try the method of taking out the battery and leaving for an hour etc. and will let you know if it works. Thanks all!
    10-29-14 11:32 AM
  12. cbvinh's Avatar
    I will try the method of taking out the battery and leaving for an hour etc. and will let you know if it works. Thanks all!
    It might need to be left alone overnight. I had this situation happen to a Q10. I fussed with it with the battery (in/out) and connected it to USB, though not try to reload the OS. I left it alone overnight, without the battery, and the next day it booted right up after inserting the battery. If the hour method works, that would be great. Please report back.
    10-29-14 11:37 AM
  13. Ron Caron's Avatar
    You can also try removing the battery completely. Then connect the phone (without the battery in it) with a USB cable to your PC, then fire up BlackBerry Link on the PC. It should recognize the phone and ask if you want to install the latest software.

    If it fails at first, leave it attached via USB without the battery and uplug/re-plug the USB from the phone and wait a few seconds.
    10-29-14 11:51 AM
  14. benbraun322's Avatar
    People don't seem to read your problem..

    Send from PassportSQW100-1/10.3.1.632
    Does the computer make any noises when you plug it in to the USB port, because if it does I think you'll be able to do autoloader method.

    Posted via CB10
    10-29-14 12:09 PM
  15. laserx's Avatar
    Had the exact same issue with a Z30, no way to fix it so it had to go back and be replaced.
    10-29-14 12:23 PM
  16. green_ember's Avatar
    My Z10 did that. I fiddled around a lot an eventually through witchcraft and invoking several technology deities I was able to get it back. Good luck!
    10-29-14 01:14 PM
  17. pkcable's Avatar
    People don't seem to read your problem..

    Send from PassportSQW100-1/10.3.1.632
    Actually on a nuked OS there are often little or no signs of life, or just light as he described. So I provided a blog link and also autoloader instructions for him to try. Yes it MIGHT also be a physical problem and a repair or replacement may be in order! We are trying and YES we read it.
    skinnymike1 likes this.
    10-29-14 02:02 PM
  18. benbraun322's Avatar
    Actually on a nuked OS there are often little or no signs of life, or just light as he described. So I provided a blog link and also autoloader instructions for him to try. Yes it MIGHT also be a physical problem and a repair or replacement may be in order! We are trying and YES we read it.
    Agreed me and pkcable to know how to read....
    We also attempt to solve problems.
    It could just be his Z10 got bricked and an autoloader may fix that.

    Posted via CB10
    10-29-14 02:15 PM
  19. Matt Somers's Avatar
    Thanks everyone. Believe me, I do appreciate everyone's help. You guys are taking time out of your day to give me suggestions. I will try the idea of taking the battery out for an hour, then charging etc. and see if it works and I might take it to a store to have someone take a look and see what they think. I will let you know what happens.

    So far I haven't been able to get the device to blink for more than a second and I can't get it to connect with BB link with the battery in or out. Will autoloader or any of the other ideas work in this case?
    10-29-14 04:05 PM
  20. benbraun322's Avatar
    Thanks everyone. Believe me, I do appreciate everyone's help. You guys are taking time out of your day to give me suggestions. I will try the idea of taking the battery out for an hour, then charging etc. and see if it works and I might take it to a store to have someone take a look and see what they think. I will let you know what happens.

    So far I haven't been able to get the device to blink for more than a second and I can't get it to connect with BB link with the battery in or out. Will autoloader or any of the other ideas work in this case?
    Does your computer make any sound saying that a device had been connected?
    I would try an autoloader.... it'll wipe your device but it might work.

    Posted via CB10
    10-29-14 05:35 PM
  21. Norman Diero's Avatar
    hey Mr. Matt Somers Have you Solve Your Problem About your Z10 that wont turn ON..?
    12-27-14 10:37 AM

Similar Threads

  1. Snap on Passport
    By Rockopool in forum BlackBerry Passport
    Replies: 20
    Last Post: 01-02-15, 03:23 PM
  2. Anyone else having issues with Blackberry in Canada or the US
    By Will Bondy in forum Service Outages
    Replies: 6
    Last Post: 10-29-14, 01:39 PM
  3. A BBM group for Z10 users all over the world
    By SailingChen in forum BlackBerry Z10
    Replies: 1
    Last Post: 10-29-14, 11:30 AM
  4. How can I get the ringer back on my phone?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 10-29-14, 11:10 AM
  5. Car kit default setting on Z30
    By draftex in forum BlackBerry Z30
    Replies: 1
    Last Post: 10-29-14, 10:01 AM
LINK TO POST COPIED TO CLIPBOARD