1. Dauntless08's Avatar
    Hey Guys! I just want to ask if you have already experienced LTE connectivity here in the Metro and where? Been using my BBZ30 for a month and I haven't seen the 4G icon yet. Always getting 3G or H+

    Posted via CB10
    03-21-15 01:39 PM
  2. rairhoz's Avatar
    But you're using an LTE capable sim right?
    If so, them better check your Z30's Mobile Network Settings...


    via BlackBerry Passport
    Last edited by rairhoz; 03-23-15 at 08:22 AM.
    03-21-15 02:05 PM
  3. Dauntless08's Avatar
    Hmm. Not so sure. I didn't know I should upgrade my sim. I'm on a Globe post paid plan, I didn't take my sim there when I got my phone replaced. I gut my sim cut from the store where I purchased my Z30. The 4G option shows up on my network settings though.

    Should I go to a Globe store to get my sim checked?

    Thanks for the response!

    Posted via CB10
    03-22-15 01:50 AM
  4. Notna Nosyel's Avatar
    Visit any globe store and have your sim replace by an LTE capable sim card.

    Posted via CB10
    Dauntless08 likes this.
    03-22-15 02:10 AM
  5. thalawan's Avatar
    Hey Guys! I just want to ask if you have already experienced LTE connectivity here in the Metro and where? Been using my BBZ30 for a month and I haven't seen the 4G icon yet. Always getting 3G or H+

    Posted via CB10
    Hi Dauntless, what is your Z30 model number? On what network you are? Globe network has lte band 3, Smart has lte band 1. The following z30 and its lte bands:
    1. Z30 STA100-1 : supports LTE bands 2,4,5, and 17 quad band
    2. Z30 STA100-2 : supports LTE bands 1, 3, 7, 8, and 20 quad band
    3. Z30STA100-3 : supports LTE bands 4, 13 quad band
    4. Z30 STA100-4 : supports LTE bands 4,12, 25 tri band
    5. Z30STA100-5 : supports LTE bands 4,5, 7 tri band

    Please check your model number. In addition, you should use an LTE ready sim and also subscribe to an LTE plan. I guess your area is covered with LTE. The matter then would be on your Z30 or your sim.

    Hope this helps.

    Posted via CB10
    Dauntless08 likes this.
    03-22-15 04:17 AM
  6. Dauntless08's Avatar
    Hi Dauntless, what is your Z30 model number? On what network you are? Globe network has lte band 3, Smart has lte band 1. The following z30 and its lte bands:
    1. Z30 STA100-1 : supports LTE bands 2,4,5, and 17 quad band
    2. Z30 STA100-2 : supports LTE bands 1, 3, 7, 8, and 20 quad band
    3. Z30STA100-3 : supports LTE bands 4, 13 quad band
    4. Z30 STA100-4 : supports LTE bands 4,12, 25 tri band
    5. Z30STA100-5 : supports LTE bands 4,5, 7 tri band

    Please check your model number. In addition, you should use an LTE ready sim and also subscribe to an LTE plan. I guess your area is covered with LTE. The matter then would be on your Z30 or your sim.

    Hope this helps.

    Posted via CB10
    I have a Z30 STA 100-2. Based on your information, I am in LTE band 3 because I am a Globe postpaid subscriber. Thanks for the info though, it helped a lot.

    I guess I'll just talk to a Globe store and get my sim replaced for an LTE capable one. Will update this thread when I have replaced my sim. Thanks for all the responses!

    Posted via my amazing BlackBerry Z30 STA 100-2
    03-23-15 12:28 PM
  7. raino's Avatar
    Hi Dauntless, what is your Z30 model number? On what network you are? Globe network has lte band 3, Smart has lte band 1. The following z30 and its lte bands:
    1. Z30 STA100-1 : supports LTE bands 2,4,5, and 17 quad band
    2. Z30 STA100-2 : supports LTE bands 1, 3, 7, 8, and 20 quad band
    3. Z30STA100-3 : supports LTE bands 4, 13 quad band
    4. Z30 STA100-4 : supports LTE bands 4,12, 25 tri band
    5. Z30STA100-5 : supports LTE bands 4,5, 7 tri band
    I think you have the STA100-2 mixed up with STA100-6. In other words, the STA100-2 does not have LTE band 1, the -6 does. If you've seen otherwise, can you provide a source that documents this?
    03-23-15 01:05 PM
  8. Dauntless08's Avatar
    Here's the link of Z30 Bands:

    http://www.berryreview.com/2013/09/1...ands-sta100-x/

    Update: I have already talked to a Globe CSR and they confirmed that my sim is not LTE Capable. Will replace my sim soon. Thanks for the heads up guys! Case closed.

    Posted via my amazing BlackBerry Z30 STA 100-2
    03-24-15 10:46 AM
  9. raino's Avatar
    Oh right...the BerryReview/BBin article. Well, it's wrong. For one, there's no STA100-9, that's actually the -6. An FD-LTE phone for China doesn't even make sense. Plus there are other errors in there. So at best, that was an early configuration and the final devices were not spec'd the same.

    I'm glad it worked out for the OP.
    Dauntless08 likes this.
    03-24-15 01:47 PM

Similar Threads

  1. Garmin connect on passport
    By widge34 in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 03-23-15, 06:28 PM
  2. Is there a fix for the Parsing issue on the z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-21-15, 02:50 PM
  3. Why have ANDROID apps stopped working on my BB Passport?
    By amit singh2 in forum BlackBerry Passport
    Replies: 1
    Last Post: 03-21-15, 01:17 PM
  4. Replies: 0
    Last Post: 03-21-15, 10:29 AM
  5. Wy can I receive buy not send or open emails on my Z10?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-21-15, 07:14 AM
LINK TO POST COPIED TO CLIPBOARD