1. CrackBerry Question's Avatar
    i just saw a new update for my z10 via bblink and i updated afterwards i can't connect my phone to bblink anymore it says device setup incomplete. what do i do?
    08-23-14 05:12 PM
  2. MobileMadness002's Avatar
    Off the top of my head I would say complete ALL steps indicated during the setup process.
    08-23-14 05:26 PM
  3. Elite1's Avatar
    When you say "it" says device setup incomplete, what's the "it"? BB Link says or your device itself says that? Is your device functional?

    Did you physically disconnect your device before it was 100% complete?

    If it was a complete failure after all, you can use BB Link to Restore Device Software. If it won't connect to Link, but your PC still detects the device, you can actually do it directly via the BB website as well.

    My first troubleshooting suggestion is to restart your PC, but I'm leery to suggest that without knowing the exact scenario.
    08-23-14 05:32 PM
  4. mauro316's Avatar
    When you say "it" says device setup incomplete, what's the "it"? BB Link says or your device itself says that? Is your device functional?

    Did you physically disconnect your device before it was 100% complete?

    If it was a complete failure after all, you can use BB Link to Restore Device Software. If it won't connect to Link, but your PC still detects the device, you can actually do it directly via the BB website as well.

    My first troubleshooting suggestion is to restart your PC, but I'm leery to suggest that without knowing the exact scenario.
    The message is on BBLink, he does not need to restore the device as it is fully functional, on top of that It will not let you do a restore from BlackBerry link anyways, all it says is you need to disconnect the device, open the setup screen on it and go over the entire setup process.

    I was just able to fix that.

    Go open your setup screen again, check every set. Then go to settings on your device. And play with every option it has from top to bottom. Restart device, restart computer. Connect to BBLink and voila, should be working.

    Its a pain in the *** and should be fixed in future updates.
    11-06-14 03:18 PM

Similar Threads

  1. Twitter for BlackBerry 10 or Blaq
    By drfever in forum BlackBerry 10 Apps
    Replies: 7
    Last Post: 09-26-14, 09:19 PM
  2. I dropped my z10 from my motorcycle
    By deercreekmichael in forum BlackBerry Z10
    Replies: 16
    Last Post: 08-28-14, 12:19 AM
  3. Cannot setup Yahoo Mail UK account in10.3.0.1052
    By Jcro001 in forum BB10 Leaked/Beta OS
    Replies: 5
    Last Post: 08-23-14, 05:48 PM
  4. BlackBerry z30, Z10, Q10 ?
    By Mehdi_Fiore in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 08-23-14, 04:15 PM
LINK TO POST COPIED TO CLIPBOARD