1. Hackstall's Avatar
    I have a Torch 9800.

    It was working fine until a couple of weeks or so ago. It started rebooting itself. Sometimes it would stay in a loop unless I did a battery pull.

    I have minimal apps on the phone and have not installed a new app for quite some time and so I determined that the operating system must have become corrupted.

    I decided to wipe and reinstall OS 6 following Joseph Holden's, "BlackBerry 302: A complete wipe and clean install of your BlackBerry OS".

    I downloaded and installed BBSAK and downloaded and installed OS v6.0.0.3049 for my particular mobile carrier.

    I wiped with BBASK. The wipe was successful as the phone rebooted and is displaying the Error 507 screen.

    I then atmpted to install the new OS using BBASK. I got to the Device Application Selection Menu and made my selections and clicked "Next" to install. The phone then shut down and would get to the reboot screen but then immediately shut down and continued this while BBASK was attempting to "Connecting to Boot Rom". After a couple of minutes, BBASK stopped trying to connect and terminated the installation - "Unable to complete loading operation - loader was unable to connect to device".

    After BBASK stopped trying to connect to the phone, the phone rebooted and is again displaying the "Error 507" white screen.

    I repeated this process several times with the same results.

    I researched but could not find help for this issue. Thanks.
    11-25-14 12:28 PM
  2. DaFoxGrey's Avatar
    Try this:
    Instead of using BBSAK to reload the OS, use the Loader.exe that comes with the OS.
    Jump to step 11 on the link here:
    How to Install/Upgrade a Blackberry Operating System
    11-25-14 01:32 PM
  3. Hackstall's Avatar
    I tried using Loader.exe with the exact same results. I was sure to delete the vendor.xml file.

    The phone is stable while displaying the Error 507 screen.
    11-26-14 09:02 AM
  4. DaFoxGrey's Avatar
    What OS is on the PC you are using?
    11-26-14 09:46 AM
  5. TOphotog's Avatar
    Hate to tell you but I don't think it's a software issue - it's most likely hardware issue. I had this happening on my Tour. Because it did it within warranty, they replaced the phone. They nicely migrated everything over to the new phone for me! Apparently this problem is standard when a phone has gotten wet, even if you dried it out and it was working. Corrosion. My phone hadn't gotten wet but it was faulty electronics inside the phone.
    11-26-14 09:55 AM
  6. Hackstall's Avatar
    I am running Windows 7 64bit.

    I think you might be right TOphotog. I have tried everything to no avail.

    About half an hour ago I tried another install (probably my 20th attempt) and it caused my computer to crash.
    11-26-14 12:03 PM
  7. DaFoxGrey's Avatar
    I am running Windows 7 64bit.

    I think you might be right TOphotog. I have tried everything to no avail.

    About half an hour ago I tried another install (probably my 20th attempt) and it caused my computer to crash.
    OK, last thing to try before giving up on the 9800:
    Make sure the USB port you are using on the Win7 computer is just a "USB2.x" port directly to the computer, not through a USB hub or external USB switch.
    If it is USB3.0, there are known issues with data to BlackBerry devices, switch to a USB2.0 or 2.x port.
    11-26-14 01:51 PM
  8. Hackstall's Avatar
    Nope. Looks like this one is cooked.

    DaFoxGrey, thanks for all of your help.
    DaFoxGrey likes this.
    11-26-14 09:48 PM
  9. rebroker2009's Avatar
    Are you able to connect it before it shows your pin on the loader? It's a bit tricky but it has to say unknown for that few seconds, once the pin appears it won't work

    Blackberry Passport running 10.3.1.1151
    11-26-14 10:27 PM

Similar Threads

  1. Why is my Keyboard suddenly not working?
    By Julian Buss in forum BlackBerry Passport
    Replies: 13
    Last Post: 11-23-15, 01:46 PM
  2. What Web browser do you use on your Q10?
    By skstrials in forum BlackBerry Q10
    Replies: 23
    Last Post: 12-07-14, 03:36 AM
  3. Passport black friday deal - $500 on Amazon
    By rider997 in forum BlackBerry Passport
    Replies: 12
    Last Post: 11-26-14, 12:00 AM
  4. I deleted my service books and lost my browser icon, what did I do?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-25-14, 07:38 PM
  5. Replies: 2
    Last Post: 11-25-14, 02:14 PM
LINK TO POST COPIED TO CLIPBOARD