1. CrackBerry Question's Avatar
    my blackberry z10 just switched off whilst i was connected to the internet. the battery had power but on trying to switch it on it showed the blackberry logo then a battery with an exclamation mark. i tried so many times but with no success. i tried to load software via autoload but still no success. please help
    08-24-14 03:43 AM
  2. Dazlr Boy's Avatar
    May be its an OS problem that has been removed in 10.2.2 as 10.2 was showing wrong signs of battery status or battery issue.may be the battery needs to be replaced

    @dazlr
    08-24-14 04:13 AM
  3. santhoshmanikandan's Avatar
    I do get this if my phone gets very hot. Leave your phone to cool and try re booting

    Z10STL100-1/10.3.0.1052
    08-24-14 04:25 AM
  4. Tyche101's Avatar
    there shouldn't be any problems with your phone, per se. try cooling down the battery and maybe replacing it.

    Zeeeeeeeeeeee ^_^
    08-24-14 07:28 AM

Similar Threads

  1. Bar files for z10 stl100-1 10.3.0.700
    By Vishal Singh3 in forum Ask a Question
    Replies: 14
    Last Post: 08-26-14, 12:09 PM
  2. Cant download music from anywhere onto my Z10...
    By nathan1973 in forum Ask a Question
    Replies: 1
    Last Post: 08-25-14, 08:09 AM
  3. My Z10 literally died
    By adrian apostol in forum Ask a Question
    Replies: 2
    Last Post: 08-24-14, 04:24 PM
  4. BBM on Q10...
    By velkod in forum Ask a Question
    Replies: 2
    Last Post: 08-24-14, 12:32 PM
  5. BB Z10 - inverted image overlaid on top of correct image
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-24-14, 08:13 AM
LINK TO POST COPIED TO CLIPBOARD