1. CrackBerry Question's Avatar
    Hi - My device was used when temperatures dropped to -10C. It was slow to respond to any commands.
    Once back at positive temperatures I noticed it would not switch back on.
    When hooked up to power, the "blackberry" logo comes on screen for a few seconds before disappearing. After a few moments the red blinking notification light comes on for a few seconds then stops.
    The whole process repeats itself over and over but it never powers up?
    The device is only 6 months old.
    Any thoughts please?
    07-28-16 07:57 PM
  2. thurask's Avatar
    Uh, maybe try an OS reload?
    07-28-16 11:18 PM
  3. thunderbird2's Avatar
    Thanks I was going to try that but have about a 100 passwords in the Password Keeper Ap and I assume I will lose all of them with a reload?
    07-29-16 12:35 AM

Similar Threads

  1. Replies: 16
    Last Post: 03-19-17, 02:37 AM
  2. Replies: 82
    Last Post: 10-26-16, 02:31 AM
  3. i did a factory reset and cant get pass the wifi setting
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-29-16, 05:06 PM
  4. Apple has reportedly hired BlackBerry's ex-QNX chief to work on car project
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 2
    Last Post: 07-29-16, 08:02 AM
  5. BBM for BlackBerry 10 and Android updated with new features and enhancements
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 07-28-16, 05:22 PM
LINK TO POST COPIED TO CLIPBOARD