1. CrackBerry Question's Avatar
    HELP! I cant get past the logo loading stage. I have read various threads and have tried everything.. even tried reloading the device software to factory settings on BB link (the pc doesnmt detect my phone) and updating from the blackberry site. even tried reloading the bb OS instructions. Nothing has worked. Tried removing SIM and media cards, etc. Please help! Anyone?
    09-03-14 02:23 AM
  2. jaydee5799's Avatar
    Are you sure you are loading the proper OS for your phone?
    09-03-14 05:26 AM
  3. Jakob Greve's Avatar
    also you should have a couple of minutes to even 5 minutes of patience especially if it locks/stops at 100% that useally means it will get there.

    (5 minites is a lot of time, when you think something is done).

    PS this only happens on rare ocasions for instance upon loading a new os.
    09-03-14 05:44 AM

Similar Threads

  1. Emojis in 10.3
    By ZMnsr1 in forum BB10 Leaked/Beta OS
    Replies: 16
    Last Post: 10-06-14, 08:46 PM
  2. A trick in the 10.3 Music Player!
    By redsaph in forum BB10 Leaked/Beta OS
    Replies: 46
    Last Post: 09-05-14, 06:43 AM
  3. Apps priority management in 10.3
    By w_scott in forum BB10 Leaked/Beta OS
    Replies: 4
    Last Post: 09-03-14, 12:13 PM
  4. My music don't working in my car
    By abdielj in forum AT&T
    Replies: 2
    Last Post: 09-03-14, 05:15 AM
  5. Where in the world is Kevin ?!!?
    By ehroberts in forum Site Feedback & Help
    Replies: 1
    Last Post: 09-02-14, 10:28 PM
LINK TO POST COPIED TO CLIPBOARD