1. renejupp's Avatar
    Hi folks!!
    Need your help please... My husband I both have Z10's - have had them sine Feb 2013. His started acting funny 3 days ago. Cannot access Settings menu at all, Cannot access Mobile network or Wireless. Sim has a message "Sim card from unknown source" - this is the same sim card he got from our network 18months ago, it has not been changed, not been tampered with. Any advice please?? His phone is an expensive paperweight at the moment. We've noticed his APN settings are blank - tried to update it but it won't allow to SAVE anything. My phone is still 100%, is just his that's gone wonky

    HEEEELP!!!! Thanks!!!
    08-20-14 08:14 AM
  2. anon1727506's Avatar
    Try switching SIMs....

    If it's the card, you need to get a new one from your carrier.

    It might be his phone... could try a secutiy wipe or reload the OS. But do a full Backup first. Test the phone with the SIM before doing a restore.
    08-20-14 08:22 AM

Similar Threads

  1. No Outgoing Mails From 2nd Email Account
    By Skyf_x in forum Ask a Question
    Replies: 20
    Last Post: 08-25-14, 08:26 AM
  2. Browser bar from 10.3.1052 simulator
    By chudypee in forum BB10 Leaked/Beta OS
    Replies: 19
    Last Post: 08-20-14, 10:40 PM
  3. Email don't send from outbox until re-open SWS
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 08-20-14, 07:21 AM
  4. Twittly - A new native Twitter client from Nemory Studios in the works
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 08-20-14, 01:51 AM
  5. Replies: 4
    Last Post: 08-19-14, 11:12 PM
LINK TO POST COPIED TO CLIPBOARD