1. CrackBerry Question's Avatar
    BB Z10 does not charge or Boot.

    3 days ago it started to heating up and discharging quickly.
    day before yesterday it discharged completely overnight and had shut down. After that it is neither booting up nor charging.
    It looks like this.
    1. Continuous red light glows
    2. Display shows white Blackberry sign with logo
    3. Display shows big charging sign
    4. Display shows big unplugged sign
    5. Display goes black.

    The process repeats if I click on the power button.

    Z10 is not recognized by my BBLink on Mac as well as Win7.
    Online autoloader also does not recognize it.
    Any suggestions.
    07-03-14 11:23 PM
  2. ronfc's Avatar
    How about if you leave it charging for about 10 minutes, does it turn ON by itself?
    07-04-14 03:43 AM
  3. wasimn's Avatar
    No, it does not start.
    07-04-14 05:13 AM
  4. bobshine's Avatar
    Did you try a different battery ?

    Posted via CB10
    07-04-14 05:16 AM
  5. wasimn's Avatar
    don't have access to another battery.


    If battery is the problem, BBLink should recognize it without the battery, which it does not.
    07-04-14 07:05 AM
  6. ronfc's Avatar
    don't have access to another battery.


    If battery is the problem, BBLink should recognize it without the battery, which it does not.
    Then it's time to get it checked or repaired. The overheating could have fried something on the motherboard that's why it doesn't boot.

    Cave, cave, moderator videt
    07-04-14 07:12 AM
  7. wasimn's Avatar
    OK. So I managed to fix this thing.

    Took the battery out, bought a cheap circuit that charges batteries, charged the battery for an hour, and it works.
    My guess is the overheating had discharged the battery below the perceived 0%.

    Also found the cause of overheating. Using multiple alarms heats my Z10 and drains the battery. Anyone has had a similar experience?
    07-07-14 12:27 AM
  8. ronfc's Avatar
    OK. So I managed to fix this thing.


    Took the battery out, bought a cheap circuit that charges batteries, charged the battery for an hour, and it works.
    My guess is the overheating had discharged the battery below the perceived 0%.


    Also found the cause of overheating. Using multiple alarms heats my Z10 and drains the battery. Anyone has had a similar experience?
    Perhaps your problem is associated with this:

    KB36038 - Fully depleted battery may not charge when BlackBerry Z10 smartphone is connected to charger

    If a battery has been depleted to a point where the smartphone powers itself off, and is then left in the smartphone for a period of time, the smartphone will not power on, even after connecting to a power supply.

    This issue is most probably been resolved on the latest OS update, 10.2.1.3247.
    07-07-14 06:57 AM

Similar Threads

  1. Will my Z10 plan/SIM work in S5?
    By ShaneN. in forum General BlackBerry Discussion
    Replies: 22
    Last Post: 07-07-14, 03:42 AM
  2. Replies: 1
    Last Post: 07-05-14, 08:09 AM
  3. Are the Blackberry screen protectors glossy or matte?
    By JWWDUKE in forum BlackBerry Z30
    Replies: 6
    Last Post: 07-04-14, 08:10 AM
  4. Blackberry Z10 Stuck in Factory Setup Mode
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-03-14, 09:14 PM
  5. Replies: 2
    Last Post: 07-03-14, 07:35 PM
LINK TO POST COPIED TO CLIPBOARD