1. Vishal Singh3's Avatar
    I updated my phone to the latest software last and even then the battery was draining like mad but I thought it might take time.It was on charge the whole night and I have used to for 10minutes and battery is 80% and I have done nothing.And the weird thing is that battery does not drain by a percent but 4-5% at a single time.
    Any idea?

    Posted via CB10
    08-26-14 11:22 PM
  2. kalonjie's Avatar
    Turn off NFC

    Posted via CB10
    08-26-14 11:56 PM
  3. Vishal Singh3's Avatar
    It is turned off.

    Posted via CB10
    08-27-14 10:55 AM
  4. altaf.s's Avatar
    Do secuity wipe after you install the new os, this helped me.
    Vishal Singh3 likes this.
    08-27-14 10:57 AM
  5. Vishal Singh3's Avatar
    I did a security wipe before installing,tomorrow I will do it again.

    Posted via CB10
    08-27-14 12:15 PM
  6. eidsonb's Avatar
    For the first couple of days the drain is more, in my experience as the phone is settling in, updating contacts and the such. Give it a day or two. My Z30 lasts well over 16 hours with Wifi and Bluetooth
    08-27-14 02:16 PM
  7. jon4400's Avatar
    Security wipe is after installation lol

    Posted via CB10
    08-27-14 03:35 PM
  8. muyaad's Avatar
    I did a security wipe before installing,tomorrow I will do it again.

    Posted via CB10
    Do it after installation and don't restore, you'll see the difference

    Love my Z10 looking for its successor or go for Z30 when the price is right for me
    08-27-14 05:09 PM
  9. Vishal Singh3's Avatar
    I don't think security wipe fixed the issue.
    Now battery meter is showing the same percentage and I know it will turn off at that percentage,and then again serious draining and will last hours at 0%.

    Posted via CB10
    08-28-14 08:45 AM
  10. Aashish Tyagi's Avatar
    If ur phone is having problem while connecting to a mobile network...in dat case battery goes discharge very fast..thats ol i knw...

    Posted via CB10
    08-28-14 09:37 AM
  11. Vishal Singh3's Avatar
    The problem is not draining,its just that it shows wrong percentage of battery left.

    Posted via CB10
    08-28-14 10:35 AM

Similar Threads

  1. Can't use BlackBerry link on new laptop!!
    By darkhorse321 in forum Ask a Question
    Replies: 13
    Last Post: 10-09-14, 01:26 AM
  2. Why Does Sachesi Freeze During 10.3.0.1052 Loads
    By llamax in forum BB10 Leaked/Beta OS
    Replies: 25
    Last Post: 08-29-14, 07:10 PM
  3. Password lock ,any changes in 10.3 os
    By Aditya Purohit in forum BlackBerry Z10
    Replies: 5
    Last Post: 08-27-14, 03:17 AM
  4. AT&T 10.2.1.3014 OS update
    By Armagedona in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 08-27-14, 12:21 AM
  5. AT&T rolling out 10.2.1.3014 software update
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 08-26-14, 11:01 PM
LINK TO POST COPIED TO CLIPBOARD