1. CrackBerry Question's Avatar
    Hi all,

    Updated to 10.2.1.2941 about a week ago and I have noticed my Q10 getting very hot and the battery is draining like crazy. As soon as I start using the browser for example it will start to drain at a ridiculous rate. It's really annoying because before the update my battery life was amazing. Have others been finding this as well? I have given it a week because I thought it would settle down but I am now concerned that this is permanent. Can anyone offer some advice on what I should do? I have done a factory reset, but it is the same. Is there a way to return to the previous firmware? Not sure why they would release an update that makes the battery life much much worse....

    All responses are much appreciated!
    06-14-14 06:14 AM
  2. backfire101's Avatar
    Did you check what's eating your battery?
    06-14-14 06:18 AM
  3. wassana7's Avatar
    How can I do that? I have been into the app monitor and it looks as though 'System' is the top user, but I can't see where it drills down into more detail than that. Help!
    06-14-14 06:29 AM
  4. wassana7's Avatar
    *logged into my account btw
    06-14-14 07:32 AM
  5. backfire101's Avatar
    did you try to delete mail accounts and add them again?
    06-14-14 07:51 AM
  6. wassana7's Avatar
    Yeah I did that also. I thought it had fixed it because it did seem to become more stable after but just fired up the browser and it got very hot again and drained from over 30% to 8% in about twenty minutes and then turned off.
    06-14-14 09:02 AM
  7. backfire101's Avatar
    did you install an app that works with the browser? ie some sort of anti virus app? since you did an OTA must be some setting disturbing the browser. is a clean install an option?
    06-14-14 10:02 AM
  8. wassana7's Avatar
    How would I do a clean install? I did a factory reset and re-updated after that. Would you recommend doing that again? Or using a sideloader type deal?
    06-14-14 10:19 AM
  9. backfire101's Avatar
    autoloader deal, in topic from lengend? i hope i spell his name correct. get the autoloader for your phone. it wil do a clean install. do not restore from a backup, because the error could be in your backup.
    06-14-14 01:54 PM
  10. wassana7's Avatar
    Thank you very much for all your help. It is much appreciated. Just in terms of an update, it does seem to have calmed down but it is still looking nowhere near what it was. I have 80% battery remaining and it is saying that will last 12 hours, where before that would've lasted another 20+ hours easily given my usage. Concerning.
    06-14-14 03:20 PM
  11. backfire101's Avatar
    It took a week for my phone to get better battery life then the previous os, so stick to it and don't mind the estimate, not really spot on.
    06-14-14 03:52 PM

Similar Threads

  1. Z30 video recording - lighting/exposure shifts like crazy
    By classact in forum BlackBerry Z30
    Replies: 7
    Last Post: 06-15-14, 04:08 PM
  2. BBM using all my battery?
    By geHuC in forum BlackBerry 10 OS
    Replies: 10
    Last Post: 06-14-14, 02:38 PM
  3. Link for 10.3 for STL100-1?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 2
    Last Post: 06-14-14, 01:25 PM
  4. Z10 battery level stuck at 100%
    By donnie990 in forum BlackBerry Z10
    Replies: 9
    Last Post: 06-14-14, 12:48 PM
  5. Get some free F1 action on your BlackBerry 10 smartphone with Thumb Formula Racing
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 06-14-14, 03:30 AM
LINK TO POST COPIED TO CLIPBOARD